* Login   * Register * FAQ
It is currently Wed Jun 28, 2017 12:19 pm

All times are UTC - 5 hours


Forum rules


Only post questions involving engines, mods, stuff that requires wrenches, specialized tools or would otherwise interest grease monkeys here please. Questions about top cases, mirrors, seats and other accessories, tires, etc. will be moved to Open Discussion.



Post new topic Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Sat Jun 20, 2015 3:00 pm 
Offline
Poster Child

Joined: Sat Jun 16, 2012 6:14 pm
Posts: 6
Scooter Model(s): honda helix and custom
Hello i have a 2005 Genuine Stella 150cc that runs great , headlight works, however its only charging about 6volts. So after about a day with a fresh battery and everything working.. Batteries dead, no horn, blinkers, starter.. Anyone have Good knowledge of the charging circuit. Ive swapped stators, and voltage regulator and did nothing. Switching module doesn't look burnt But there could be a short in the wire some were... I'm a good mechanic and electrician but don't have time to dig into it. Hope you can Help! Ty Mike


Top
 Profile  
Reply with quote  
PostPosted: Thu Jul 02, 2015 10:02 am 
Offline
50cc Lane Splitter

Joined: Sun Jan 29, 2012 12:56 pm
Posts: 125
Scooter Model(s): longbo LB-150-2 GTS 250ie
look into the regulator or stator.

John

_________________
Image


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: Bing [Bot], Google Adsense [Bot] and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum


Powered by phpBB® Forum Software © phpBB Group